RealTimeToDB System Requirements

RealTimeToDB System Requirements

Tested RTD Servers

  • FutureSource, eSignal
  • RealTimeToExcel (former Gartle RTD Server), Gartle Technology Corporation

Tested DDE Servers

  • ThinkDesktop, Thinkorswim, division of TD Ameritrade
  • Trader Workstation, Interactive Brokers
  • VertexFX Trader, Hybrid Solutions

Supported Architectures:

  • x86
  • x64

Supported Operating Systems:

  • Windows XP SP3, Vista SP1, 7, 8, 8.1, 10
  • Windows Server 2003 SP3, 2008, 2008 R2, 2012, 2012 R2

Supported Versions of Microsoft SQL Server:

  • Microsoft SQL Server 2005, 2008, 2008 R2
  • Microsoft SQL Server 2012, 2014 including Express LocalDB
  • Microsoft Azure SQL Database

Supported Versions of Microsoft SQL Server Compact:

  • Microsoft SQL Server Compact 3.5, 4.0

Supported Versions of Oracle Database:

  • Oracle Database 10g Release 1, Release 2
  • Oracle Database 11g Release 1, Release 2
  • Oracle Database 12c Release 1

Supported Versions of IBM DB2:

  • IBM DB2 9.5, 9.7, 10.1

IBM DB2 .NET Provider, IBM DB2 OLE DB Provider or IBM DB2 ODBC driver installed is required.

Supported Versions of MySQL:

  • MySQL 5.0, 5.1, 5.2, 5.5, 5.6

Supported Versions of SkySQL MariaDB:

  • MariaDB 5.1, 5.2, 5.3, 5.5, 10.0

All application features for MySQL are completely compatible with MariaDB.
ADO.Net Driver for MySQL and MySQL ODBC drivers can be used to connect to MariaDB.
MariaDB ODBC Driver 1.0 is not supported.

Supported Versions of NuoDB:

  • NuoDB 2.0.4, 2.2

Supported Versions of PostgreSQL:

  • PostgreSQL 9.0, 9.1, 9.2, 9.3, 9.4
This website is using cookies. By continuing to browse, you give us your consent to our use of cookies as explained in our Cookie Policy.